Resolved | May 29, 2026 | 09:08 GMT+02:00
There were unexpected delays for supporter exports and newsletter integrations (April 23rd to May 20th) and for webhook events (April 23rd to May 28th).
All data events from this time period have now been processed and delivery rate has returned to normal.
Monitoring | May 20, 2026 | 08:00 GMT+02:00
Between 23 April - 20 May, webhook events, supporter exports and newsletter integrations experienced unexpected data delays.
All data events from this time period have now been processed and delivery rate has returned to normal.
We are still closely monitoring the situation for the next few days.
Resolution in progress | May 13, 2026 | 06:00 GMT+02:00
Data delays are possible for submissions made after 23 April. Webhook events, supporter exports and newsletter integrations may be delayed by several days.
Our development team has already made the necessary process changes to speed up the events and prevent this from happing again in the future.
We expect the delivery rate to return to normal in the coming days and will closely monitor the situation.
Monitoring | May 07, 2026 | 08:00 GMT+02:00
We've identified delays in data deliveries for webhook events that occurred between 23 April and 1 May. Deliveries for events within this period may be delayed by several days.
We are closely monitoring webhook data deliverability over the coming days.