Incident

Delayed email delivery

Resolved | Nov 14, 2024 | 17:20 GMT+01:00

On 4 November we experienced email deliverability delays with emails sent from Impact Stack. This affected confirmation-, thank-you-, target- and password-reset-emails. The issue has now been resolved and emails are delivered as usual again.

Monitoring | Nov 04, 2024 | 15:03 GMT+01:00

The issue has been resolved and emails are delivered as usual again. We will continue to monitor the Impact Stack email delivery over the next few days.

Resolution in progress | Nov 04, 2024 | 11:26 GMT+01:00

Email delay: we have identified the issue and are working on resolving it. We expect emails to be going out at normal speed again soon.

Open | Nov 04, 2024 | 10:53 GMT+01:00

We are currently experiencing issues with email deliverability for emails sent from Impact Stack. Emails are still sent out but their delivery is delayed. This affects confirmation-, thank-you-, target- and password-reset-emails. Our hosting team is working on resolving this issue.

Status Page powered by Admin Labs