Incident

Email deliverability issues for recipients with Outlook email addresses

Resolved | Sep 18, 2025 | 08:00 GMT+02:00

We experienced issues with deliverability for email recipients with Outlook email addresses (@hotmail.com, @outlook.com, @live.com) between 24th August - 12th September 2025. This affected confirmation-, thank-you-, target- and password-reset-emails.

This issue has now been resolved and all emails from the affected timeframe have been resent.

Affected components

  • Impact Stack 2.0 : Email Sending
  • Impact Stack 1.0 : Email Sending

Monitoring | Sep 04, 2025 | 18:00 GMT+02:00

Since September 4th at 18:00 CEST, the issue appears to have been resolved again by Outlook and emails from the affected timeframe are being been re-sent.

Our hosting team will still closely monitor email deliverability over the coming days.

Waiting | Sep 01, 2025 | 15:00 GMT+02:00

Due to technical difficulties from Outlook, we continue to experience issues with deliverability for email recipients with Outlook email addresses (@hotmail.com, @outlook.com, @live.com). This affects confirmation-, thank-you-, target- and password-reset-emails.

Our hosting team is in contact with Outlook technical support to get this issue resolved as quickly as possible.

Monitoring | Aug 29, 2025 | 00:00 GMT+02:00

We experienced issues with deliverability for email recipients with Outlook email addresses (@hotmail.com, @outlook.com, @live.com) on 28th August 2025. This affected confirmation-, thank-you-, target- and password-reset-emails.

This issue appears to have been resolved and emails from the affected timeframe are being been resent.
Our hosting team will still closely monitor email deliverability over the coming days.

Investigating | Aug 28, 2025 | 06:00 GMT+02:00

We are currently experiencing issues with deliverability for email recipients with Outlook email addresses (@hotmail.com, @outlook.com, @live.com). This affects confirmation-, thank-you-, target- and password-reset-emails.

Our hosting team is in contact with Outlook technical support to get this issue resolved as quickly as possible.

Monitoring | Aug 27, 2025 | 12:00 GMT+02:00

Due to technical difficulties from Outlook, we experienced issues with deliverability for email recipients with Outlook email addresses (@hotmail.com, @outlook.com, @live.com) between 24th - 27th August 2025. This affected confirmation-, thank-you-, target- and password-reset-emails.

This issue appears to have been resolved and emails from the affected timeframe are being been resent.
Our hosting team will still closely monitor email deliverability over the coming days.

Investigating | Aug 25, 2025 | 14:00 GMT+02:00

Since Sunday, 24th August 2025 we are experiencing issues with deliverability for email recipients with Outlook email addresses (@hotmail.com, @outlook.com, @live.com). This affects confirmation-, thank-you-, target- and password-reset-emails.

Our hosting team is working on resolving this issue.

Status Page powered by Admin Labs