Incident

Interruption in outbound email delivery

Resolved | Apr 08, 2025 | 15:25 GMT+02:00

On Tuesday 8th April between 10:24 -12:53 BST / 11:24 - 13:53 CEST no emails were sent out for Impact Stack action pages (confirmation-, thank-you- and email-to-target emails are affected).

This issue has now been resolved and all emails from the affected timeframe has been resent.

Affected components

  • Impact Stack 2.0 : Email Sending
  • Impact Stack 1.0 : Email Sending

Resolution in progress | Apr 08, 2025 | 13:53 GMT+02:00

On Tuesday 8th April between 10:24 -12:53 BST / 11:24 - 13:53 CEST no emails have been sent out for Impact Stack action pages (confirmation-, thank-you- and email-to-target emails are affected).

We have applied a fix for the issue and are currently working on resending all emails from that timeframe.

Investigating | Apr 08, 2025 | 11:24 GMT+02:00

Since Tuesday 8th April ~11:24 CEST no emails have been sent out for Impact Stack action pages (confirmation-, thank-you- and email-to-target emails are affected).

We are currently working on on a solution as quickly as possible.

No data has been lost and emails will be resent as soon as the email service is operational again.

Status Page powered by Admin Labs